Jump to content

Archived

This topic is now archived and is closed to further replies.

expat42451

Manjaro Linux ESET NOD-32 GUI wont iopen

Recommended Posts

My first post. I have been using ESET NOD-32  on linux for  quite some time and this is the first problem I have experienced. 

inxi -Fxzc0 
System:
  Host: orphaned-inode Kernel: 4.14.34-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 7.3.1 Desktop: Xfce 4.12.4 (Gtk 2.24.31) 
  Distro: Manjaro Linux 17.1.8 Hakoila 
Machine:
  Type: Desktop Mobo: ASUSTeK model: TUF Z270 MARK 1 v: Rev 1.xx serial: N/A 
  UEFI [Legacy]: American Megatrends v: 1203 date: 12/25/2017 
CPU:
  Topology: Quad Core model: Intel Core i7-7700 type: MT MCP arch: Skylake 
  rev: 9 L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 57616 
  Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 801 2: 800 
  3: 800 4: 801 5: 800 6: 800 7: 800 8: 800 
Graphics:
  Card-1: NVIDIA GK208 [GeForce GT 730] driver: nvidia v: 390.48 
  bus ID: 01:00.0 
  Display Server: x11 (X.Org 1.19.6) driver: nvidia 
  resolution: 1366x768~60Hz, 1366x768~60Hz, 1366x768~60Hz 
  OpenGL: renderer: GeForce GT 730/PCIe/SSE2 v: 4.6.0 NVIDIA 390.48 
  direct render: Yes 

is the system.  Using htop I can see the esets_daemon running. Looking at /var/log/esets I see entries for sched.dat, stats.inet, stats.mail, stats.mailpart, stats.onaccess,stats.ondemand,and status.dat all from today as well as eventlog.dat. When I try to open the GUI a window flashes briefly and disappears. Additionally the icon has disappeared from the launcher bar. I tried using the repair function in the executable  and it failed to remedy the problem after a reboot.

I have also run rkhunter and tiger and dont see anything alarming. Any help or guidance would be appreciated. I generally run  a full system scan  2-3 times per week.

Regards and thanks.

 

Edit--later. Re downloaded and installed another copy from Esets,  same result with a fresh install file.

Share this post


Link to post
Share on other sites

Hello expat42451

It is very easy and intuitive. I make it work in few minutes, here you can find the steps and screenshots.

To use the multilib repository, uncomment the [multilib] section in /etc/pacman.conf (Please be sure to uncomment both lines):

edit /etc/pacman.conf

#[multilib]
Include = /etc/pacman.d/mirrorlist

Install glibc to run  32 bit packages:

pacman -S lib32-glibc

Install cpio package

pacman -S cpio

 

pic01.jpg

pic02.jpg

pic03.jpg

Share this post


Link to post
Share on other sites

JJ

 First many thanks for the time and interest  you devoted to your  post, it is very appreciated.

In /etc/pacman.conf multilab is already uncommented. cpio is already installed. When I sudo pacman -S lib-glibc I have  error:target not found. After this I ran Yaourt and attempted to "find"glib-c and it returned nothing so I am at a bit of a loss here.

 

Many thanks for your interest and kind assistance.

Regards

 

Share this post


Link to post
Share on other sites

Hello

 

Do not use sudo. Open terminal, login as roor using sudo su. Run command as mentioned it shoud work :)

Please let me know how it went

Share this post


Link to post
Share on other sites

Hi JJ

Same result as root through the terminal, error:target not found.  Weird yes??

 

Regards and thanks

Share this post


Link to post
Share on other sites

JJ

Got lib32- glibc installed. Reinstalled Eset and rebooted. Same result. No  AV window at reboot, refused to start the GUI at all. Here is the core dump.

 Process 1073 (esets_gui) of user 1000 dumped core.
                                                       
                                                       Stack trace of thread 1073:
                                                       #0  0x00007f8921dd2a48 _dl_relocate_object (ld-linux-x86-64.so.2)
                                                       #1  0x00007f8921dda933 dl_open_worker (ld-linux-x86-64.so.2)
                                                       #2  0x00007f891e3e4b64 _dl_catch_error (libc.so.6)
                                                       #3  0x00007f8921dda27a _dl_open (ld-linux-x86-64.so.2)
                                                       #4  0x00007f891e981e86 n/a (libdl.so.2)
                                                       #5  0x00007f891e3e4b64 _dl_catch_error (libc.so.6)
                                                       #6  0x00007f891e982587 n/a (libdl.so.2)
                                                       #7  0x00007f891e981f22 dlopen (libdl.so.2)
                                                       #8  0x00007f891effe312 n/a (libX11.so.6)
                                                       #9  0x00007f891effe44f _XNoticeCreateBitmap (libX11.so.6)
                                                       #10 0x00007f891effea61 XCreatePixmap (libX11.so.6)
                                                       #11 0x00007f892131a066 n/a (libgdk-x11-2.0.so.0)
                                                       #12 0x00007f89212e5399 gdk_pixbuf_render_pixmap_and_mask_for_colormap (libgdk-x>
                                                       #13 0x000000000045fae0 n/a (esets_gui)
                                                       #14 0x000000000041ac9c n/a (esets_gui)
                                                       #15 0x000000000048179e n/a (esets_gui)
                                                       #16 0x00007f891e2d3f4a __libc_start_main (libc.so.6)
                                                       #17 0x000000000040de5a n/a (esets_gui)
lines 7-37/37 (END)

Regards and thanks

Share this post


Link to post
Share on other sites

Hello @expat42451 ,

it seems that the GUI is crashing on your system.

We would need the coredump and stack trace (from the same crash) to look into it.

To capture the stack trace:

1. Stop esets service

2.run command ulimit -c unlimited
to enable complete dumps

3. Please run the esets_daemon with the strace parameter
"strace -ffo esets_daemon.txt -s 256 /opt/eset/esets/sbin/esets_daemon"

4. Please run the esets_gui with the strace parameter
"strace -ffo esets_gui.txt -s 256 /opt/eset/esets/bin/esets_gui"

5. Wait till issue occurs again and take all esets_daemon.txt*, esets_gui.txt*, and /tmp/bt.* files 

6. Download the info_get  script from http://ftp.nod.sk/~jedovnicky/info_get.command.1.37.zip run it and take the output. 

7. Pack and upload all the outputs to a safe location and send me a private message with a reference to this topic.

Regards, P.R.

Share this post


Link to post
Share on other sites

Hi Peter

Many thanks for your and JJ's kind assistance.  I bought the program  a while ago and it was excellent.  However plans here are changing, I have uninstalled it and the computer it was used on is going away in the next week or so.  I run both OSX and the same Manjaro  distro on my laptop dual boot as I do  on the  desktop  that had NOD32 on it. However I am preparing for a move and dont have the time to address this right now.  After a few things here setle down I may possibly attempt an install on my laptop and to readdress it then.   NOD32 has been running in a production environment on Manjaro and has until this problem, been excellent. 

 

Again many thanks  for your kindness and willingness to help. I am only sorry I do not have the time to assist you in resolving this problem.

Share this post


Link to post
Share on other sites

Hello @expat42451,

you are welcome, @J.J. was assisting you, personally I have minimal experience with Linux magic :-(

Not an issue it seems to work in our environment so it won't be a general issue with Manjaro and our product.

Thank you for your positive feedback and I hope everything will go as expected with your moving.

Regards, P.R.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...