Jump to content

ESET hiding PC from printer/scanner, can't send scans to PC


Recommended Posts

Let me start by saying this is a mess. A couple weeks ago we had to setup a VPN to allow a remote connection to some software that we use. And that started a nightmare. The VPN simply refused to work with ESET running. Over the last couple weeks, and insane amounts of googling (ESET website has too much information for google to provide quality search results), I found the "Interactive Mode" which allowed me to create custom policies for the VPN to work. And then the nightmare got worse. Every last stupid little piece of software that even thinks about using any part of the network or the internet needs a policy to be able to work. I literally had to sit at the computer all day, doing nothing, waiting for all the software on the system to do some kind of network related task (like check for updates) so ESET would give me the popup that would allow me to setup a new policy.  I think I have 20 some odd pieces of software (email client, browser, remote backup late in the day) that all needed policies, all the PC's on the local network needed a policy, and even the network printer had to have a policy. Even as I sit here typing this I am not sure every policies I need is setup.

But one last thing is not working. The network printer has a scanner and it allows a person to select what PC you send a scan to (handy for emailing invoice copies). But the printer/scanner does not see the one PC (the one that has all these custom policies) unless I disable ESET.  And as it does not see the one PC you can send a scan to it. Hoping someone knows of work around for this.

Edited by ShaneH
Link to comment
Share on other sites

  • Administrators

1, Make sure that the VPN network is trusted. The first time the computer connected to the VPN, you should have been offered an option to mark it as home/office (trusted) network or public. Later you can change it in the advanced setup -> firewall -> known networks.

2, As the name suggests, in interactive mode you are asked whether to allow or block particular communications. It's possible to create the necessary rules in interactive mode and then switch back to automatic mode. Or use learning mode to create rules first and then switch to interactive mode for instance. In your case I assume that marking the VPN connection as trusted will resolve possible issues with firewall blocking desired communication.

3, I assume that temporarily pausing firewall makes a difference and that marking the network as trusted would also resolve this issue. In untrusted (public) networks, sharing and some other communications are disabled. Should the problem persist, create a separate topic for this. We'll need you to: 1, enable advanced firewall logging in tools -> diagnostics, 2. reboot the computer, 3. reproduce the issue, 4. disable logging and collect logs with ELC.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...