Jump to content

Archived

This topic is now archived and is closed to further replies.

Ladderman

Steam not looking right

Recommended Posts

Hi

Ever since i started using Steam on a wifi network,Steam hasn't been looking right.Please see this thread i started on the Steam forums:-

hxxp://steamcommunity.com/discussions/forum/1/2860219962081648570/

I have tried adding an exception in my ESET Smart Security Premium firewall,but the problem stil persists.I am now asking for some advice on what to do next,or show me how i should be configuring ESET Smart Security Premium properly so that Steam looks okay again.

Thanks

Colin

Share this post


Link to post
Share on other sites

Does temporarily disabling protocol filtering in the advanced setup make a difference? If not, what about pausing the ESET firewall ?

Share this post


Link to post
Share on other sites

Probably steamwebhelper being blocked , make sure you have these 3 items set up like this picture :)

Have shown the paths to each file you need to allow as they are not all in the same directory

 

ss.jpg

Share this post


Link to post
Share on other sites
19 minutes ago, cyberhash said:

Probably steamwebhelper being blocked , make sure you have these 3 items set up like this picture :)

Have shown the paths to each file you need to allow as they are not all in the same directory

 

ss.jpg

Hi Cyebrhash

Where do i put the exceptions as described in your image?.I put the exceptions in Firewall/Advanced/Exceptions,but i'm guessing it was the wrong part of ESET Firewall.

Colin

Share this post


Link to post
Share on other sites
2 minutes ago, Ladderman said:

Hi Cyebrhash

Where do i put the exceptions as described in your image?.I put the exceptions in Firewall/Advanced/Exceptions,but i'm guessing it was the wrong part of ESET Firewall.

Colin

Hi @Ladderman


If you just open the main ESET gui , then press F5 . That will take you to the advanced setup. From there go to  FIREWALL > ADVANCED > RULES > click edit

Then manually add the rule within there :)

Share this post


Link to post
Share on other sites
5 hours ago, Marcos said:

Does temporarily disabling protocol filtering in the advanced setup make a difference? If not, what about pausing the ESET firewall ?

Hi Marcos

Where is the protocol filtering in the advanced setup?.Have tried pausing the ESET firewall,but Steam still looks the same.

Colin

Update: I found it under Web and E-mail.It didn't didn't make any difference when i disabled it and restated Steam.

Share this post


Link to post
Share on other sites

Hi Cyberhash

I added the new rules,but Steam still looks the same.

Colin

Share this post


Link to post
Share on other sites

Maybe you can try re-installing Steam?

I also use Steam and don't have these kinds of problems...

Share this post


Link to post
Share on other sites

Does the issue actually go away after temporarily uninstalling ESET?

Share this post


Link to post
Share on other sites
1 hour ago, Daedalus said:

Maybe you can try re-installing Steam?

I also use Steam and don't have these kinds of problems...

Hi Daedalus

I tried re-installing Steam with Administrator privileges,but that didn't work.

Colin

 

Share this post


Link to post
Share on other sites
2 minutes ago, Marcos said:

Does the issue actually go away after temporarily uninstalling ESET?

I temporarily disabled ESET's firewall and temporarily disabling protocol filtering.Bth didn't work.Thanks for the suggestions though,i'm at a loss as what to try.

Colin

Share this post


Link to post
Share on other sites
21 hours ago, Ladderman said:

I temporarily disabled ESET's firewall and temporarily disabling protocol filtering.Bth didn't work.Thanks for the suggestions though,i'm at a loss as what to try.

Colin

I think Marcos was asking about whether the issue goes away if you completely uninstall ESET and reboot your machine.

Share this post


Link to post
Share on other sites

Hi

Okay,i unstalled ESET and then reinstalled it again.All the while checking to see if Steam was looking right.No joy i'm afraid.Going to update my graphics card drivers to see if that helps.

Colin

Share this post


Link to post
Share on other sites

Did the issue go away after uninstalling ESET (and before re-installing it) ?

Share this post


Link to post
Share on other sites
7 hours ago, Marcos said:

Did the issue go away after uninstalling ESET (and before re-installing it) ?

No,Steam was still not looking right.

Share this post


Link to post
Share on other sites
33 minutes ago, Ladderman said:

No,Steam was still not looking right.

Then that means the issue is not caused by ESET. If you have another computer in the network and install the Steam client on it, does the issue manifest as well?

Share this post


Link to post
Share on other sites

Hi Marcos

I went on my Girlfriends laptop,and went on store.steampowered.com,and the store page was still messed up.So it's not my PC...

(we live in the same flat and share the wifi,although the router in the flat complex is there for anybody who signs up to the Wifinity service.Have i made sense there?).

Colin

As a side note,i can't buy anyhting on Steam now.When i do click on the price(no button) turns red and nothing happens.

Share this post


Link to post
Share on other sites

Perhaps you could try connecting through a different network / ISP and see if it makes a difference.

Share this post


Link to post
Share on other sites

Are there any other sites/services that don't load correctly? Does the network in question have WPA or similar encryption, or is it an unencrypted public network with a captive portal?

Share this post


Link to post
Share on other sites

Based on my experience, if the issue keep recurring, there probably something wrong with your Wireless Device. You might want to check with them if even after you UNINSTALL the ESET without installing it again and tested it, the problem are still exist.

do you own the wifi device? try to check it settings etc. 

Why im saying this? because at the forum you mention that using ethernet cable the website load without any problem.

And another thing is try change the dns setting of your pc wireless settings to google public dns, and see if that makes any changes.
8.8.8.8
8.8.4.4

On 4/4/2018 at 4:49 AM, Ladderman said:

(we live in the same flat and share the wifi,although the router in the flat complex is there for anybody who signs up to the Wifinity service.Have i made sense there?).

And another thing is based on the above statement, though this is really rare case, but it still happened, your wifi might a little crowded which also might cause the issues. I have experience this once because the wifi are shared with a few people, and the wifi became somehow crowded, which led to this kind of problem. 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...