Jump to content

Scheduled Scan Not Running


Recommended Posts

I've manually created 2 scheduled scans and they don't run at the specified time, or at all. Deleting and recreating the tasks has not resolved the issue. I've also disabled and re-enabled the tasks.

If the tasks are skipped, they are configured to run immediately if the last run exceeds 24 hours. See the attached are screenshots for additional information on the task details.

My computer is running Windows 10 with ESET Internet Security 11.0.159.9. The computer is also configured to turn off the screen after 10 minutes of inactivity, but the Sleep setting is configured for 'Never'.

Any suggestions on what I could try?

screenshot1.JPG

screenshot2.JPG

Link to comment
Share on other sites

  • Administrators

Try creating a task that will start calc.exe in a few minutes. Does it start alright while you are logged in?

Link to comment
Share on other sites

Just tried it. In this scenario, it shows the task was last run at the specified time but it didn't actually open the calculator. Also tried it with another program (Chrome) and again, it shows it was run at the specified time but the browser didn't open.

At least it shows the tasks for the calculator and Chrome were run, as opposed to the computer scan tasks I've setup that show nothing under 'Last run'.

Edited by Mario M
More info
Link to comment
Share on other sites

On 3/1/2018 at 4:03 PM, Marcos said:

Try creating a task that will start calc.exe in a few minutes. Does it start alright while you are logged in?

As mentioned in my previous post, it shows the task did run while I was logged in. Does this mean there is a conflict between running scheduled tasks when the screensaver is running or if the screen is turned off due to inactivity?

Link to comment
Share on other sites

I've only had ESET on my Windows 10 computer for a few days, but I did note that a scheduled scan that should have run did not. I had it set to run ASAP if missed, but I think (can't be certain) that my PC was running and I was logged on at the time. I have another scheduled scan due to run on Sunday, so it will be interesting to see if it runs then.

Link to comment
Share on other sites

I've just tried creating a test task, after which I turned off my computer, waited until the time had passed and then turned it back on to see if the missed task would run. It hasn't run yet, so it doesn't look as though it's going to. It does seem that if my computer happens to be on at the time then the tasks are running, but not if it is switched off, so it would seem that my situation is similar but not exactly the same as the OP. I'm also running on Windows 10 64-bit and using the latest version of Internet Security.

Scheduled Task Screenshot.jpg

Scheduled Task Screenshot 2.jpg

Link to comment
Share on other sites

The problem described in the previous posting from @BrianE is a bug that exists (at least for some users) since version 9.

 

I posted about this problem more than 2 years ago here in this forum

Version 9 and 10: scheduler - log maintenance

and until today nothing has changed for me.

Edited by User
Link to comment
Share on other sites

I've just tried it again with a different task and it's still not worked with my computer off at the time the task was due to run.

Missed Scheduled Task.jpg

Missed Scheduled Task 2.jpg

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...