Jump to content

Silent / Unattended installs - ADMINCFG option not working


NBPC
 Share

Recommended Posts

Trying to get Nod32 Antivirus to install in a truly unattended method used to be done by downloading the MSI and install via a script.

The new version 11.x versions failed due to the new EXE version and new installer parameters being passed.

As per ESET the MSI install method is a rejected method and wants the ESET home products install using the EXE 

After some juggling and information requests the script to silently install using the EXE file is given below

This is for Nod32 Antivirus 64bit -

eav_nt64.exe --silent --accepteula --language 1033 --msi-property-ehs PRODUCTTYPE=eav --msi-property ADMINCFG="path-to\Config.xml"

The EXE method works well except the option --msi-property ADMINCFG="path-to\Config.xml" does not apply the settings

During the MSI install the option /ADMINCFG="path-to\config.xml" worked perfectly. (and still does if the MSI is extracted from the EXE)

Without the ability to apply the settings during install, this is not an unattended method

The old MSI method requires extracting the MSI from the EXE and now requires a registry entry to be injected prior to install or it fails, It is an easy fix to make the MSI method work but ESET wants the EXE method used.

I have tried different locations installation and the Config.xml to assure permissions where not an issue.

I am looking for any help or information or ideas to apply the ADMINCFG option

The new version 11.x looks like they are using Advanced Installer to build the package. Hoping someone may know a trick to pass the MSI switch through the EXE options

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...