Jump to content

ERA Server 6.5 connection is abnormal


sdnian
 Share

Recommended Posts

In recent months after the update to ERA 6.5, sometimes Web Console cannot login (I can see the login screen, but hang after click login button). Then I checked the ERAServer.exe have a lot of connections. There are about five connections normally. In the trace.log file.. there are many log like this:

2018-02-22 00:41:03 Information: NetworkModule [Thread 370]: Forcibly closing sessionId:16355, isClosing:0
2018-02-22 00:41:03 Information: NetworkModule [Thread 370]: Removing session 16355
2018-02-22 00:41:03 Information: NetworkModule [Thread 370]: Closing connection , session id:16355
2018-02-22 00:41:03 Information: CReplicationModule [Thread 1958]: CReplicationManager: Connection was closed by remote peer.
2018-02-22 00:41:06 Warning: NetworkModule [Thread 718]: The connection will be closed due to timeout. SessionId:16357 Ip address: 192.168.25.234 Port: 58714 Resolved name: 192.168.25.234
2018-02-22 00:41:06 Information: NetworkModule [Thread 370]: Forcibly closing sessionId:16357, isClosing:0
2018-02-22 00:41:06 Information: NetworkModule [Thread 370]: Removing session 16357
2018-02-22 00:41:06 Information: NetworkModule [Thread 370]: Closing connection , session id:16357
2018-02-22 00:41:06 Information: CReplicationModule [Thread 1958]: CReplicationManager: Connection was closed by remote peer.
2018-02-22 00:41:07 Warning: NetworkModule [Thread 370]: The connection will be closed due to timeout. SessionId:16358 Ip address: 192.168.26.240 Port: 13889 Resolved name: 192.168.26.240

Usually, just force to kill the ERAServer.exe process (It can't be stop ERA Server from services in this moment) and then start the service will return to normal.

This ERA server is v6.5.522.0, Windows Server 2012 R2 x64. About 550 clients (Most are Agent 6.5.522, EES 6.6.2072, EFSW 6.5.12014). This server work well before upgraded 6.5. It's probably been in use for two years.

But not only this server happened, There are some ERA 6.5 servers have the same issue. (I helped over 100 customers install and maintain the ERA server.)

Screenshot_2018-02-22_08-37-14.png.39376bd3560ab930f3f42701d6ea3e5b.png

Link to comment
Share on other sites

  • ESET Staff

Hello @sdnian, I have briefly talked to developers, and they are not aware of any such issues reported before. So the best thing would be to open a ESET customer care ticket, with the logs. Most likely, we might need a full memory dump from a state, when there is "too many" connections, to properly determine the root cause of the issue. But please, as stated, open a customer care ticket, so this can be followed-upon the proper way.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...