Jump to content

6.5.2107.1 removed from repository?


j-gray
 Share

Recommended Posts

Just noticed that are install tasks are failing because this version has been removed from the repository.

Regardless if I check or uncheck the 'Legacy' option, I only have two package options; 6.5.2118.2 or 6.6.2072.2

Were the legacy packages removed intentionally, or is there an issue with the repository?

Link to comment
Share on other sites

  • Administrators

Only currently available installers contain current modules. If you installed an older package, it could happen that Windows would start crashing because of an issue with the Anti-Stealth driver and a recent Windows update.

As of ESMC (ERA v7), installation tasks will be invalidated automatically so that they cannot be re-used to install a version which is no longer available in the repository.

Link to comment
Share on other sites

12 minutes ago, Marcos said:

Only currently available installers contain current modules. If you installed an older package, it could happen that Windows would start crashing because of an issue with the Anti-Stealth driver and a recent Windows update.

As of ESMC (ERA v7), installation tasks will be invalidated automatically so that they cannot be re-used to install a version which is no longer available in the repository.

Thanks for the reply.

So does that mean that only the most recent version will be available in the repository going forward?

Link to comment
Share on other sites

  • Administrators
7 minutes ago, j-gray said:

So does that mean that only the most recent version will be available in the repository going forward?

Not really. We have always kept even older installers in the repository, however, if we discover a serious issue with them, we need to remove them and thus prevent users from installing a version which might cause serious issues, such as BSOD in this case.

Link to comment
Share on other sites

Is it possible to have the install task use whichever version is available instead of a specific build?

For instance, have it install version 6.5 regardless of the "sub-build" of that version. That way the task won't be broken by fixes/improvements automatically applied in the repository.

If not available now, could this be in ERA 7?

Link to comment
Share on other sites

  • ESET Staff

@dcomer We have a backlog request for that for a while, however we need to come up with a solution, that will meet legal requirements (changes of EULA between versions). It won’t be made for 7.0, but there is a lot of demand for such change and some underlying architecture changes are planned to allow us to do this change. 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...