Jump to content

Error Message

Recommended Posts

Since installing NOD32 Antivirus I have a new error message:

Error: ld.so: object 'libsets_pac.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored

In the Forum I found this

log in show " ld.so: object 'libesets_pac.so' from /etc/ld.so.preload cannot be preloaded: ignored."

By RandyWang, January 8, 2016 in ESET Products for Linux Servers


This answer was provided by Slated:

ESET advises against setting LD_PRELOAD globally:

 It is important that the ‘LD_PRELOAD‘ environment variable is defined only for the network server daemon processes (ftp, Samba, etc.) that will be under
control of the On-access scanner. Generally, preloading LIBC calls for all operating system processes is not recommended, as this can dramatically slow the
performance of the system or even cause the system to hang. In this sense, the  ‘/etc/ld.so.preload‘ file should not be used, nor should the ‘LD_PRELOAD‘
environment variable be exported globally. Both would override all relevant LIBC calls, which could lead to system hang-up during initialization.

To ensure that only relevant file access calls within a given file system are intercepted, executable statements can be overridden using the following line:



I have just recently moved from Windows to Linux and so I'm still a beginner therefore I was hoping someone could advise me which file I should insert this line into. Thanks in advance.



Didn't mention the distro..

Currently I have Debian 8.9 installed on my PC though as soon as 9.3 arrives in the mail I'll try installing that to see if it helps.


The bug is a sleeper

At first apart from the annoying error messages everything seemed to work until I changed my USB modem. It wouldn't connect properly only as a wired connection and when I deleted these connections and tried to add a new one my problems started. None of modems would connect, I couldn't connect to the blu-ray drive with the file manager (although fortunately I was able to do a backup with Xfburn) and I couldn't access my flash drive. So I followed MonkeeSage's  advice:



Edit /etc/ld.so.preload as super user and change:




Save the file and the library will be preloaded for new processes. You should restart the system to make it active for all processes.



This worked but if Slated's advice is correct then I still would like to know in which file the line:


should be entered. If someone could help I'd be most grateful.



Now I'm having trouble with the laptop I'm getting the same error:

"ld.so: object 'libesets_pac.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored"

So I went to edit /etc/ld.so.preload as before the only problem being it doesn't exist, so what do I do now?


Can anyone help please?



Edited by Debian
More problems...
Link to comment
Share on other sites

  • ESET Moderators

Hello @Debian

were you able to resolve the issue or you need an assistance from our side?

If yes please provide us with a log created according to this article https://support.eset.com/kb6159/ from our knowledge base. 


Link to comment
Share on other sites

  • ESET Moderators

Hello @Debian,

a colleague shared a workaround, which might help you, can you please try it and let us know how it went?

Please create a symlinks and type "libesets_pac.so" into the "ld.so.preload" file.

A/ create symlink for 64bit "n -s /opt/eset/esets/lib64/libesets_pac.so /usr/lib64/libesets_pac.so"
B/ create symlink for 32bit "n -s /opt/eset/esets/lib/libesets_pac.so /usr/lib/libesets_pac.so"
C/ set in ld.so.preload file only "libesets_pac.so"

In case you perform all mentioned steps and the issue will persist please provide us with a new set of logs.

Regards, P.R.

Link to comment
Share on other sites

Thanks Peter, everything was OK with Debian 8.9 until I reinstalled NOD32 Antivirus on the PC. So I decided to install 9.3, hoping this would fix the bug and it's fine on the PC but not with the Asus Laptop, which was a problem as soon as I installed NOD32 Antivirus. Both computers were setup with the same software, drivers etc, so could the problem be hardware related? Anyhow I'm trying again this time with OpenSuse, being a rpm based distro, I'm hoping this will work without problems. I will let you know how it goes.



Link to comment
Share on other sites

Well Peter I'm pleased to report that after installing OpenSuse 42.3 with NOD32 Antivirus on both computers they are both running fine with no bugs. That's the good thing about Linux if one distro doesn't work for you there are always others.


Christopher Jensen

Link to comment
Share on other sites

  • ESET Moderators

Hello Christopher,

thank you for sharing your experience I'm glad it works for you now.

The colleague who shared the workaround with me told me that this issue happens only on some distributions.

Regards, P.R.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...