Jump to content

Exclude groups from report


fchelp
 Share

Recommended Posts

Hi there

I'm trying to generate a report of all failed server tasks, except if the clients are in specific static groups,

steps that i did

  1. I set up a report template with these settings
    2017-12-18_094246.png.4d7527c093d59953157c46c36fd2809e.png
  2. And i'm trying to filter the results to show me all, but a few static groups
    2017-12-18_094422.thumb.png.7f79f7a354680b2000cd0d93a723fe10.png

But for some reason it's impossible to set a filter to exclude a group, much less multiple groups.

  1. When i add the condition "Static group . Static group" and set the value to ≠ (Not equal) to WhateverGroup it generates a report with only that group, instead of all but that group.
  2. Let's say this bug is fixed, we still can't exclude multiple groups, as,
    • When choosing ≠ (Not equal) we can't select more then one group
    • There is no "Not in" option to choose from in the drop down menu for condition, only a "In" option.
      2017-12-18_095438.thumb.png.1058f4d8269f26bd6635ff381e14514e.png
    • Even if i decide to use a workaround and set the Value to "In" and select all groups except the ones i want to exclude, it won't work as then the report fails
      2017-12-18_092808.png.d1b480933690b9d6e7c0dc7f3a4474d2.png

 

Thanks in advance.

Edited by fchelp
Rewritten full post to explain myself clearly
Link to comment
Share on other sites

  • ESET Staff

The first option is not currently possible. I will have to check with developers, whether "not in" will be doable in the upcoming release. 

There is possible to select "in" ,and choose multiple items.  

Link to comment
Share on other sites

48 minutes ago, MichalJ said:

The first option is not currently possible. I will have to check with developers, whether "not in" will be doable in the upcoming release. 

There is possible to select "in" ,and choose multiple items.  

I rewrote the first post to clarify clearly what the issue is.

I hope now it's easier to fully understand. (and duplicate)

Thanks

 

Edited by fchelp
Link to comment
Share on other sites

  • ESET Staff

As of now, we can only admit, that the behavior your have described is correct. I will report a bug, that will hopefully be fixed in the future versions. Specifically adding the "not in" filter, and checking, why the "not equal" does not work as expected. I am going to replicate this by myself, to check / and maybe suggest a workaround. Thank you for your patience. 

Edited by MichalJ
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...