Jump to content

HTTPS and Google


Go to solution Solved by User,

Recommended Posts

With https protection activated in ESS and using Firefox 25

I get the error that the connection can not be trusted for the sites:

 

https://maps.google.com

https://translate.google.com

https://drive.google.com

https://news.google.com

https://mail.google.com

etc.

 

and also www.youtube.com

 

I have to make an exemption for every site in the certificat manager in Firefox.

Is this normal?

 

Other https sites are working without problems.

Link to comment
Share on other sites

  • Administrators

I'm able to open Google websites as well as other https websites in Firefox 25 and SSL scanning enabled fine. Could you post a screen shot of the warning you're getting?

Link to comment
Share on other sites

There is also a problem with google's image search in Firefox with https protection on:

 

A lot of pictures are not loaded in every search. And when I scroll down no more pictures are loaded.

post-2177-0-74311000-1383915078_thumb.jpg

Edited by User
Link to comment
Share on other sites

I have an opposite situation. I added a website to block but I still can access it. It is confirmed that the list is not working probably.

Link to comment
Share on other sites

Do you have this problem when opening the page in Internet Exporer?

 

No, in Internet Explorer 10 it is working.

Link to comment
Share on other sites

Advanced setup->Web and email->Protocol filtering->SSL

Select "Do not scan SSL protocol" and your firefox starts working again. I had this problem suddenly occur for the first time mid last week. Checked this option instead of "Always scan SSL protocol" and it all went back to normal. Would be nice if you guys at ESET could fix this, or figure a way that we can prevent this from happening as there is no way you can turn it on in the webbrowser to make content show temporarily.

Link to comment
Share on other sites

Advanced setup->Web and email->Protocol filtering->SSL

Select "Do not scan SSL protocol" and your firefox starts working again.

 

I think it is better only to deactivate https protection under ->HTTP, HTTPS.

If you deactivate SSL, e-mails are not scanned if you use POP3S or IMAPS.

 

Anyway I hope this will be fixed soon by ESET.

 

It seems to me that Firefox does not fully accept ESET's security certificate for google websites as it says "this connection is untrusted".

Edited by User
Link to comment
Share on other sites

The problem with ssl for me seems to be Mozilla related certs are blocked by eset , if you select to trust them, it then blocks them, select exclude  they stay unblocked, also v7 for me keeps loosing stored cert permissions, and sometimes  eset ssl will prevent/delay a web page loading until the pop up is generated by eset  for you to trust or exclude the ssl cert of that site this is using ie 7 on a win xpsp3 machine

v6 didn't display issues like this, except for the firefox ssl issues they where present in v5 maybe even v4

Link to comment
Share on other sites

I searched a little bit further and found this in the ESET knowlegebase: KB Solution ID: SOLN3126

 

ESET is aware of this issue and is working on a product update that will allow Mozilla Firefox to access websites that use SSL certificates with SSL scanning enabled.

 

Now I'm sceptical, if a solution to this problem can be expected soon, as this was posted over a year ago.

Link to comment
Share on other sites

  • 2 weeks later...

I had opened a support ticket with German ESET support and they confirmed that there is still no fix for this problem.

They suggested to disable SSL protection as recommended in the ESET knowlagebase.

Link to comment
Share on other sites

  • Administrators

I'm getting an error sec_error_inadequate_key_usage, is it the same error as you're getting? I've found the same issue reported by a Kaspersky user here: hxxp://support.mozilla.org/en-US/questions/950736. It seems that connection to google, youtube and maybe some other servers is not allowed by Firefox when a self-signed certificate is used. Tested with Opera and IE, no problem accessing the websites noticed.

Link to comment
Share on other sites

I'm getting an error sec_error_inadequate_key_usage, is it the same error as you're getting?

 

Yes, I made a new screenshot:

post-2177-0-95612100-1385252867_thumb.jpg

Link to comment
Share on other sites

Tested with Opera and IE, no problem accessing the websites noticed.

 

Yes, in Internet Explorer 10 it seems to work, as I said above.

 

Also Google Image search looks really strange in Firefox, see the pic in Posting #4.

Only two or three lines of pics are loaded and the rest is grey squares, but no error message is displayed.

Edited by User
Link to comment
Share on other sites

  • ESET Moderators

Hello,

 

the issue "sec_error_inadequate_key_usage" is fixed in Internet protection module: 1092, we are testing it now internally.

I will let you know when it will be released for pre-release users.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...