Jump to content

Error 1923 When Upgrading to ESET Endpoint AV 6.6.2046.0


Recommended Posts

I've successfully upgraded almost all the computers in my office to the new version of ESET Endpoint Antivirus version 6.6.2046.0 with no issue by deployment with the MSI installer from ESET's website by using Admin Arsenal PDQ Deploy for deployment.  However, there are currently 2 computers that I am unable to install the new version on.  The system logs in event viewer in computer management on them are showing error as follows:

"Product: ESET Endpoint Antivirus -- Error 1923. Service 'ESET Service' (ekrn) could not be installed.  Verify that you have sufficient privileges to install system services."

The computers completely uninstalled ESET Endpoint Antivirus version 6.5.2107.1 on upgrade and left the computer unable to reinstall or upgrade as the service "ESET Service" or ekrn is left behind and cannot be stopped or reinstalled.

On the affected computers, the following is what I've tried as well as the results:

- Deleted ESET service ekrn in regedit.  After doing so, I'm able to reinstall 6.5, then do an uninstall through appwiz.cpl of ESET to get a clean uninstall of the software.  After, I've tried installed version 6.6 and there is still an error 1923.

- I've also tried removing the software using ESET Remote Administrator by removing ESET Remote Agent and ESET Endpoint Antivirus and redeploying the newest version, but still receive the same error 1923.

- I've also tried using the ESET removal tool provided on https://support.eset.com/kb146/?locale=en_US   then reinstalled with no luck on the new version.

Both computers are on Windows 10, one on patch level 10.0.14393.1593, and the other on 10.0.15063.540.

I have a few other offices to upgrade the software on, so I'd like to be prepared with a solution should it come up again.  Any help would be greatly appreciated.


Link to comment
Share on other sites

Test this out on one of your affected hosts:

Completely uninstall ESET Endpoint AV through Control Panel >  Programs > Programs and Features

Do not uninstall the ERA Agent.

Reboot the PC.

Deploy 6.6.2046 through the ERA.

Reboot the PC again.

I ran into a hiccup with 6.6.2046 and Win10 that was solved by just doing a clean install.  I use PDQ Deploy as well but never used it for ESET since upgrades can be done right from the ERA.

Link to comment
Share on other sites

I tried doing this but receive error:

When installing through ESET Remote Administrator, I see error in event viewer:

"Product: ESET Endpoint Antivirus -- Error 1920.  Service 'ESET Service' (ekrn) failed to start.  Verify that you have sufficient privileges to start system services." 

When running MSI on the computer:

Service 'ESET Service' (ekrn) failed to start.  Verify that you have sufficient privelages to start system services.

The installation begins but gets stuck at starting the ESET service.

Link to comment
Share on other sites

  • ESET Moderators

Thanks for providing great info about the issue and the troubleshooting steps you've taken to attempt to resolve. There are a few other steps to try that I've learned from our Technical Support agents, but I would rather that you open a Support case so they can track this issue, because it's something we will want to make sure we resolve not just in this instance, but for others as well -- opening a case will allow our TS agents to escalate this to development if needed to resolve the issue. 

Email Tech Support using the online form: https://www.eset.com/us/support/contact/#/business-support

Or you can do live chat, right now:  https://helpus.eset.com/

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...