Jump to content

[SOLVED] Eset - Firefox Bug - "Secure Connection Failed" SSL HTTPS pages not loading


MarcFL

Recommended Posts

BUG REPORT
RE:  Eset NOD32 v10.1.219.0 does NOT work properly with new Firefox 55.0 (64-bit) on Windows 10.

When "Enable HTTPS Checking" in ON in Eset (under advanced setup, web access protection, web protocols)  pages do NOT load properly in Firefox.
Error:  Secure Connection Failed.  SEC_ERROR_BAD_SIGNATURE

This is an intermittent issue.

Sample Page - Does Not Load At All
false "Secure Connection Failed" error
https://forums.laptopvideo2go.com/

Sample Page - Many elements on the page do not load
hxxp://support.eset.com/

Sample Page - Does not load at all
false "Secure Connection Failed" error
https://www.oo-software.com/en/shutup10

Sample Page - Does Not Load At All
false "Secure Connection Failed" error
https://forum.eset.com/

 

 

Connection Failed.jpg

Link to post
Share on other sites

Had the same thing once and if i remember correctly all i done to resolve the problem was to switch off HTTPS checking , close Firefox and then re enable HTTPS checking and start Firefox again.

Link to post
Share on other sites

SOLUTION:
I tried this and it seems to be working.  I will test for a longer period since it was an intermittent issue.  Update:  OK, it's still working.  Solution final.

In some cases, the root certificate is not properly imported during the installation of ESET products. This issue is often resolved by disabling and then re-enabling SSL/TLS scanning (be sure to click OK after disabling and enabling).   This will re-add "the root certificate to known browsers" again. See attached picture and detailed instructions below.
Follow Instructions Here ===>>>   hxxp://support.eset.com/kb3126/

Related, but not directly relevant:  hxxp://support.eset.com/kb6004/

 

Root Certificate.jpg

Link to post
Share on other sites
  • 3 weeks later...

RE:  Firefox - Secure Connection Failed.  SEC_ERROR_BAD_SIGNATURE
Whenever a major Windows update is installed (Windows 10 Creators Update for example), Firefox exhibits this issue.  The solution as mentioned above is to Uncheck "Add the Root Certificate to Known Browsers", click OK.  Then go back and Check it again.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...