Jump to content

ERA not starting after few days running on 6.5 version


martyz
 Share

Recommended Posts

Hi guys, after few days running ERAS Virtual Appliance (upgraded from 6.3 to 6.5) suddenly ERA web service stopped working, after restart VM it is same - webUI says

HTTP Status 404 -
type Status report
message
description The requested resource () is not available.
Apache Tomcat/6.0.24

and after stoping and starting tomcat 

/etc/init.d/tomcat6 start

/usr/share/tomcat6/logs/catalina.out says

Apr 06, 2017 11:44:31 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib
Apr 06, 2017 11:44:32 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8443
Apr 06, 2017 11:44:32 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 831 ms
Apr 06, 2017 11:44:32 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Apr 06, 2017 11:44:32 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.24
Apr 06, 2017 11:44:32 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory era
Apr 06, 2017 11:44:32 AM org.apache.catalina.core.StandardContext resourcesStart
SEVERE: Error starting static Resources
java.lang.IllegalArgumentException: Document base /usr/share/tomcat6/webapps/era does not exist or is not a readable directory
	at org.apache.naming.resources.FileDirContext.setDocBase(FileDirContext.java:142)
	at org.apache.catalina.core.StandardContext.resourcesStart(StandardContext.java:4358)
	at org.apache.catalina.core.StandardContext.start(StandardContext.java:4527)
	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:526)
	at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1041)
	at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:964)
	at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:502)
	at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1277)
	at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:321)
	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:142)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
	at org.apache.catalina.core.StandardHost.start(StandardHost.java:722)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
	at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
	at org.apache.catalina.core.StandardService.start(StandardService.java:516)
	at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:593)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)

Apr 06, 2017 11:44:32 AM org.apache.catalina.core.StandardContext start
SEVERE: Error in resourceStart()
Apr 06, 2017 11:44:32 AM org.apache.catalina.core.StandardContext start
SEVERE: Error getConfigured
Apr 06, 2017 11:44:32 AM org.apache.catalina.core.StandardContext start
SEVERE: Context [/era] startup failed due to previous errors
Apr 06, 2017 11:44:32 AM org.apache.catalina.core.StandardContext stop
INFO: Container org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/era] has not been started
Apr 06, 2017 11:44:32 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory ROOT
Apr 06, 2017 11:44:32 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory era.bkp
Apr 06, 2017 11:44:32 AM sk.eset.era.g2webconsole.server.modules.logger.FileLogWriter addItem
INFO: [2017-04-06 11:44:32.754] V1 [] <INFO> ERA Web Server starting...
Apr 06, 2017 11:44:32 AM sk.eset.era.g2webconsole.server.modules.logger.FileLogWriter addItem
INFO: [2017-04-06 11:44:32.764] V1 [] <INFO> ERA Web Server Version: 6.2.155.0
Apr 06, 2017 11:44:32 AM sk.eset.era.g2webconsole.server.modules.logger.FileLogWriter addItem
INFO: [2017-04-06 11:44:32.767] V1 [] <DEBUG> ERA Web Server starting...
Apr 06, 2017 11:44:32 AM sk.eset.era.g2webconsole.server.modules.logger.FileLogWriter addItem
INFO: [2017-04-06 11:44:32.768] V1 [] <DEBUG> ERA Web Server Version:6.2.155.0
Apr 06, 2017 11:44:32 AM sk.eset.era.g2webconsole.server.modules.logger.FileLogWriter addItem
INFO: [2017-04-06 11:44:32.802] V1 [] <INFO> ERA Web Server has started.
Apr 06, 2017 11:44:32 AM sk.eset.era.g2webconsole.server.modules.logger.FileLogWriter addItem
INFO: [2017-04-06 11:44:32.804] V1 [] <DEBUG> contextInitialized
Apr 06, 2017 11:44:32 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8443
Apr 06, 2017 11:44:32 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Apr 06, 2017 11:44:32 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/18  config=null
Apr 06, 2017 11:44:32 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 575 ms

any ideas pls? Unfortunately no snapshot - no way back ...

Thank you

Link to comment
Share on other sites

selfsolved - I should have read logs carefully - somehow rights were scrambled

ll /usr/share/tomcat6/webapps/
celkem 12
drwxr-x---. 5 root   root   4096  6. dub 10.02 era
drwxrwxrwx. 5 tomcat tomcat 4096 15. zář  2015 era.bkp
drwxr-xr-x. 2 root   root   4096 28. kvě  2014 ROOT

changed ownership to tomcat and boom - webIF up and ready ;-)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...