Jump to content

Firewall doesn´t allow Remote Desktop via Internet


Recommended Posts

I'd like to access my desktop pc with my laptop using Remote Desktop from anywhere. With anywhere I mean: work, university, girlfriend house, etc.

 

The problem I have is that firewall is preventing this incoming connection, if I disable firewall there is no problem and I'm able to access my desktop pc.

 

With firewall activated I get this event in the log:

 

15/10/2013 07:07:46 a.m. No usable rule found xxx.xxx.xxx.xxx:49204 192.168.1.102:3389 TCP System

where xxx is IP adress of my laptop.

 

I can't create a rule to allow a connection from an IP that I don't know in advance. I was thinking that a way it can work is allowing incoming connections through port 3389, but I don't have a clue on how to do it and maybe is insecure.

 

Any suggestion?

Thanks in advance!

 

P.S: For security I've changed the Remote Desktop listening port, it isn't 3389, but let's suppose it is 3389 (the default)

Link to comment
Share on other sites

  • Administrators

If you want to connect from everywhere, create a new allowing bi-directional rule with the local port set to 3389 (or whichever you'll use). You can restrict remote IPs or subnets on the Remote tab. Don't forget to switch the firewall to "Automatic mode with exceptions" so that custom rules are applied.

Link to comment
Share on other sites

  • 4 months later...

Sorry to resurrect this thread, but the OP never said if the solution worked for them or not.

 

I am setting up Remote Desktop to be available from my workplace or from the Trusted Zone/Local Zone and I am having a similar issue. I have followed ALL of the steps listed above. 

 

Editing the Rule

- Ensured 3389 is set for TCP out and in allow,

- Local 3389,

- Remote 3389

- Remote address = Trusted Zone, Local Zone, any specific IPs I need to add.

 

Editing the Trusted Zone and Local Zone:

- Ensured that trusted zone and local zone have all remote IPs

 

IDS configuration:

- Ensured that Allow RDP is checked in IDS configuration

 

Results:

* When attempting to RD from my local network with ESET Firewall ENABLED, I am unable to access the host computer.

* When attempting to RD from my local network with ESET Firewal DISABLED, I am able to successfully access host computer.

 

Is there a setting I am missing somewhere? From what I can tell, and I have experience setting up software and hardware firewalls, I have everything necessary in place per your instructions.

 

Please help me resolve this, I've never had this kind of problem with other firewall software.

 

Thanks!

J

Link to comment
Share on other sites

  • Administrators

Is there a setting I am missing somewhere? From what I can tell, and I have experience setting up software and hardware firewalls, I have everything necessary in place per your instructions.

 

What firewall mode do you use? In order for rules to be applied, you must switch to other than Automatic mode.

Shouldn't that be the problem, enable logging of blocked connections in the IDS setup, clear the firewall log, reproduce the problem and then copy & paste your firewall log records here.

Link to comment
Share on other sites

  • 1 year later...

I followed the steps listed by guava1776 and posted 03 March 2014 - 10:12 PM.

I am not able to establish a remote desktop connection whether I disable the ESET firewall or not.

I am using "interactive mode".

Firewall log:

4/11/2015 11:24:10 PM TCP packet not belonging to any open connection 192.168.11.47:52695 50.28.75.27:443 TCP   
4/11/2015 11:24:10 PM TCP packet not belonging to any open connection 192.168.11.47:52696 50.28.75.27:443 TCP   
4/11/2015 11:24:05 PM TCP packet not belonging to any open connection 192.168.11.47:52696 50.28.75.27:443 TCP   
4/11/2015 11:24:05 PM TCP packet not belonging to any open connection 192.168.11.47:52695 50.28.75.27:443 TCP   
4/11/2015 11:24:03 PM TCP packet not belonging to any open connection 192.168.11.47:52696 50.28.75.27:443 TCP   
4/11/2015 11:24:03 PM TCP packet not belonging to any open connection 192.168.11.47:52695 50.28.75.27:443 TCP   
4/11/2015 11:24:02 PM TCP packet not belonging to any open connection 192.168.11.47:52696 50.28.75.27:443 TCP   
4/11/2015 11:24:02 PM TCP packet not belonging to any open connection 192.168.11.47:52695 50.28.75.27:443 TCP   
4/11/2015 11:24:01 PM TCP packet not belonging to any open connection 192.168.11.47:52696 50.28.75.27:443 TCP   
4/11/2015 11:24:01 PM TCP packet not belonging to any open connection 192.168.11.47:52695 50.28.75.27:443 TCP   
4/11/2015 11:24:01 PM TCP packet not belonging to any open connection 192.168.11.47:52695 50.28.75.27:443 TCP   
4/11/2015 11:24:01 PM TCP packet not belonging to any open connection 192.168.11.47:52696 50.28.75.27:443 TCP   
4/11/2015 11:23:33 PM No application listening on the port 137.135.12.16:443 192.168.11.47:52699 TCP   
4/11/2015 11:23:14 PM TCP packet not belonging to any open connection 192.168.11.47:52692 50.28.75.27:443 TCP   

Link to comment
Share on other sites

  • Administrators

The firewall log is useless if disabling the firewall doesn't make any difference. The entries have something to do with https communication with 50.28.75.27 so should be unrelated to the issue. Does switching firewall integration to "Personal firewall is completely disabled" and restarting the computer help?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...