Jump to content

Internet Connection drop-off on Smart Serucity 10


Recommended Posts

I'm using Smart Security 10 in my Window 10 Home computer. I can't use my internet more than 15 minutes continuously. It seems the IDS issues. This is my Home Wifi and I chosen  Home or office network as my protection mode and I used Automatic mode as my Personal Firewall. All devices in this network and some applications are trying to connect to my computer and hence it disconnects. And after sometime it automatically reconnects. I tired even Learning mode for my Personal Firewall but no use. It's very difficult to work with. Please see the attached screenshot when it disconnects. My questions are:

1. Is there any solutions for this?

2. What is the protection mode do I have to choose, Public network or Home or office network?

3. What is the Firewall filtering mode do I have to choose, Automatic mode, Interactive mode or Learning mode?

My OS: Windows 10 Home

Eset 10.0.386.0

Please help me to solve this issue.

ESET Firewall Screen.jpg

Link to comment
Share on other sites

  • Administrators

Use automatic firewall mode with no custom rules while troubleshooting the issue. Have you tried unblocking communication from trusted devices in the Firewall troubleshooting wizard.

Link to comment
Share on other sites

I have seen this quite a bit. One customer was having issue where ESS kept blocking log me in. even after choosing unblock multiple times and creating manual rule it always would show back up in this list. I had to get him on NOD32 otherwise he was going to cancel license. Why is ESET blocking devices when there are no rules specific to said devices ?  Is there a protocol its blocking and thus blocking devices ? 

Link to comment
Share on other sites

22 minutes ago, Marcos said:

Use automatic firewall mode with no custom rules while troubleshooting the issue. Have you tried unblocking communication from trusted devices in the Firewall troubleshooting wizard.

Yes, I tried unlocking all the trusted devices but the list will be full again within few minutes. I can't download a bigger files due to this issue.

Can I use Public protection mode instead of Home or office network?

I'm a web developer and I have to upload, download, test a lots of files and this is very irritating. This is even blocking my personal phone. I have another computer with Smart Secuty 9, that also blocking some trusted devices but no internet connection drop-off.

What could be the reason?

Link to comment
Share on other sites

  • Administrators
14 minutes ago, tmuster2k said:

I have seen this quite a bit. One customer was having issue where ESS kept blocking log me in. even after choosing unblock multiple times and creating manual rule it always would show back up in this list. I had to get him on NOD32 otherwise he was going to cancel license. Why is ESET blocking devices when there are no rules specific to said devices ?  Is there a protocol its blocking and thus blocking devices ? 

If you attempted to log in from outside of his trusted zone, it's normal that the firewall blocked the communication in automatic mode. In automatic mode, all non-initiated incoming communication is blocked and all outgoing communication is allowed.

This is also how Windows firewall and many other firewalls work in automatic mode.

In case of problems with a desired communication being blocked, enable advanced firewall logging under Diagnostics -> Tools and reproduce the issue. When done, disable logging and provide a customer care or moderator with the pcapng file created in the C:\ProgramData\ESET\%ProductName%\Diagnostics folder as well as with logs from ESET Log Collector for detailed analysis.

Link to comment
Share on other sites

I understand it blocking items outside of trusted zone but look at screenshot from above. why is it blocking internal 192.x.x.x. his Smart TV (LG TV)?. Also have hear of reports where it blocks their router and have to continually keep unblocking otherwise they lost internet connectivity every 30 min. 

Link to comment
Share on other sites

1 hour ago, Marcos said:

If you attempted to log in from outside of his trusted zone, it's normal that the firewall blocked the communication in automatic mode. In automatic mode, all non-initiated incoming communication is blocked and all outgoing communication is allowed.

This is also how Windows firewall and many other firewalls work in automatic mode.

In case of problems with a desired communication being blocked, enable advanced firewall logging under Diagnostics -> Tools and reproduce the issue. When done, disable logging and provide a customer care or moderator with the pcapng file created in the C:\ProgramData\ESET\%ProductName%\Diagnostics folder as well as with logs from ESET Log Collector for detailed analysis.

It's blocking inside and outside zone.

One of my friend advised me to keep the Filtering mode to "Listening mode". In that case the frequency of blockage is less, ateast I'm getting 30 minutes uninterrupted connection, but after one or two days, the issue is back again. Also, I tried disabling the firewall, but still the problem exists.

One thing I noticed is that, when I took my laptop to my office, there is no issues like this shot frequency of blockage, but it's happening may be after one or two hours.

I'll try to collect the log and get back to you.

Link to comment
Share on other sites

1 hour ago, Marcos said:

If you attempted to log in from outside of his trusted zone, it's normal that the firewall blocked the communication in automatic mode. In automatic mode, all non-initiated incoming communication is blocked and all outgoing communication is allowed.

This is also how Windows firewall and many other firewalls work in automatic mode.

In case of problems with a desired communication being blocked, enable advanced firewall logging under Diagnostics -> Tools and reproduce the issue. When done, disable logging and provide a customer care or moderator with the pcapng file created in the C:\ProgramData\ESET\%ProductName%\Diagnostics folder as well as with logs from ESET Log Collector for detailed analysis.

It's blocking inside and outside zone.

One of my friend advised me to keep the Filtering mode to "Listening mode". In that case the frequency of blockage is less, ateast I'm getting 30 minutes uninterrupted connection, but after one or two days, the issue is back again. Also, I tried disabling the firewall, but still the problem exists.

One thing I noticed is that, when I took my laptop to my office, there is no issues like this shot frequency of blockage, but it's happening may be after one or two hours.

I'll try to collect the log and get back to you.

Link to comment
Share on other sites

1 hour ago, w3sumesh said:

Can I use Public protection mode instead of Home or office network?

I see the same activity on my Wi-Fi LAN when family members visit and start connecting all their wireless devices to said LAN. 

I have since day one always used the Public profile for both Eset and the Win firewall since I do not trust any of those wireless devices and do not want them accessing anything of my PC or anything connected to it. This off course means no device sharing with the external wireless devices.

1 hour ago, tmuster2k said:

Also have hear of reports where it blocks their router and have to continually keep unblocking otherwise they lost internet connectivity every 30 min. 

Are you saying that you have multiple routers connected to your Wi-Fi LAN?

Link to comment
Share on other sites

5 minutes ago, itman said:

Are you saying that you have multiple routers connected to your Wi-Fi LAN?

No, I have only one Router. My other devices on this network trying to connect to my PC and it's blocking all the devices, inside and outside IP range, hence the connection is loosing. It auto connects after sometime.

Link to comment
Share on other sites

2 minutes ago, w3sumesh said:

No, I have only one Router. My other devices on this network trying to connect to my PC and it's blocking all the devices, inside and outside IP range, hence the connection is loosing. It auto connects after sometime.

I have the same circumstance as posted and never had a dropped connection on my PC due to external blocking activity when using the Public profile. Now I believe, I never had more than 3 or 4 devices connecting at the same time my router's wireless LAN.

Do you have the Eset firewall set to "Automatic" with also "use Win inbound firewall rules enabled?" 

 

Link to comment
Share on other sites

7 hours ago, itman said:

I have the same circumstance as posted and never had a dropped connection on my PC due to external blocking activity when using the Public profile. Now I believe, I never had more than 3 or 4 devices connecting at the same time my router's wireless LAN.

Do you have the Eset firewall set to "Automatic" with also "use Win inbound firewall rules enabled?" 

 

Yes, I'm using "Automatic" with Windows settings

Link to comment
Share on other sites

14 hours ago, Marcos said:

If you attempted to log in from outside of his trusted zone, it's normal that the firewall blocked the communication in automatic mode. In automatic mode, all non-initiated incoming communication is blocked and all outgoing communication is allowed.

This is also how Windows firewall and many other firewalls work in automatic mode.

In case of problems with a desired communication being blocked, enable advanced firewall logging under Diagnostics -> Tools and reproduce the issue. When done, disable logging and provide a customer care or moderator with the pcapng file created in the C:\ProgramData\ESET\%ProductName%\Diagnostics folder as well as with logs from ESET Log Collector for detailed analysis.

I tried to collect the log file but it's around 110MB of size. Can I send using Wetranfer?

I have another question: Why other devices are connecting to my computer? This is suppose to connect to my Router only right?

Edited by w3sumesh
Link to comment
Share on other sites

8 hours ago, w3sumesh said:

This is suppose to connect to my Router only right?

Wrong.

8 hours ago, w3sumesh said:

Why other devices are connecting to my computer?

It's called network discovery. It has been built into every version of Window since XP. By default when using a Public profile for both the Win Firewall or Eset's firewall, network discovery is disabled.

Windows by default will attempt to discover network devices using SSDP and uPnP. Here are a some references for further detail:

https://en.wikipedia.org/wiki/Simple_Service_Discovery_Protocol

https://en.wikipedia.org/wiki/Universal_Plug_and_Play

You can additionally control SSDP, uPnP, and file and printer sharing options on a home network profile using Eset's IDS advanced options settings.

Edited by itman
Link to comment
Share on other sites

On 2/2/2017 at 6:47 PM, itman said:

Wrong.

It's called network discovery. It has been built into every version of Window since XP. By default when using a Public profile for both the Win Firewall or Eset's firewall, network discovery is disabled.

Windows by default will attempt to discover network devices using SSDP and uPnP. Here are a some references for further detail:

https://en.wikipedia.org/wiki/Simple_Service_Discovery_Protocol

https://en.wikipedia.org/wiki/Universal_Plug_and_Play

You can additionally control SSDP, uPnP, and file and printer sharing options on a home network profile using Eset's IDS advanced options settings.

I kept off on all Network Discovery and sharing.

Link to comment
Share on other sites

On 2/1/2017 at 9:50 PM, Marcos said:

In case of problems with a desired communication being blocked, enable advanced firewall logging under Diagnostics -> Tools and reproduce the issue. When done, disable logging and provide a customer care or moderator with the pcapng file created in the C:\ProgramData\ESET\%ProductName%\Diagnostics folder as well as with logs from ESET Log Collector for detailed analysis.

Marcos, I have already pm the logs. Please review and suggest a solutions to solve my issues.

Link to comment
Share on other sites

20 hours ago, w3sumesh said:

Dear Admins, please give me a solution. I already shared the log files.

I guess, ESET Admins can't solve this issue.

Anyone else please............

Link to comment
Share on other sites

I had a similar issue you are experiencing when I was on Eset SS ver.9. Luckily for me, the issue didn't persist on ver. 10. Before I get into details on how to implement what I propose, I will explain what it does. Then it is up to you to decide if you want to try it.

Eset IDS protection has a setting that determines the "statefulness" of an inbound TCP connection. That is if the inbound connection was not in response to a corresponding outbound connection, Eset IPS protection will block the inbound connection. Most routers have such "stateful" capability. If your router has the same, you really don't need the corresponding Eset protection.

On ver. 9, I found that disabling the "Check TCP connection status" in the "Packet Inspection" setting of "IDS and advanced options" settings stopped the behavior you are experiencing.  Below is a screen shot of how to do this - uncheck the "Check TCP connection status" setting. Then save your changes by clicking the "OK" button for every subsequent screen displayed.

Note: If this doesn't resolve your issue, make sure you re-enable the "Check TCP connection status" setting.

 

Eset_TCP_Conn_Status.png

Link to comment
Share on other sites

Hi ITMAN, thanks for this but before trying this, please check my settings below and advise me further as my Packet Inspection settings, only 6, 7 and 8 check box has been enabled.

The below settings are by defualt.

 

589a146c96cc9_Connectednetworks.JPG.fc0bf8c523726e0473e26da0ac58b05f.JPG

589a1485eea95_networkprotection.thumb.JPG.48c2399e456992b065bb097800a57c1c.JPG

zones.thumb.JPG.05e9a4382a26aaadb6ae615afcea9ae2.JPG

basic.thumb.JPG.79b4bc95186a877528910ea26ac0efcc.JPG

advanced.thumb.JPG.e6e9be74a983db323ef79ef418ecf717.JPG

application.thumb.JPG.f99464acb09077e291b3961bb6fe3e98.JPG

589a1471ac227_firewallprofile.thumb.JPG.5182701436577514ec1d1ce91293c0af.JPG

ids1.thumb.JPG.f21db5cc4d00da2eb7e3d45eb0293745.JPG

ids2.JPG.d3a33db063d9e4199c2f173673ffa947.JPG

ids3.thumb.JPG.e0039fb4ba18fa5990f69f5079b7d363.JPG

ids4.JPG.ebf942541a620b029c53faddc66d8301.JPG

ids5.thumb.JPG.8ffc3845a25d0f72d155ebbc48cf322c.JPG

blockage.thumb.JPG.ff75f576f2397b1c2e56ed2fe85a64ec.JPG

connection.thumb.JPG.30f0b14b6ee018c70ade435029f5fb07.JPG

Link to comment
Share on other sites

I don't know why 0.0.0.0 is showing up in your assigned DNS servers in the Firewall Zones settings. I have never seen that before. Doesn't look right to me.

All Intrusion Detection settings should be enabled i.e. check marked

All Packet Inspection settings should be enabled other than the Check TCP connection status setting discussed previously if you decide to try that.

The ARP Poisoning alert is not good. You can read about that here: https://www.techopedia.com/definition/27471/address-resolution-protocol-poisoning-arp-poisoning

It's beginning to look like you might have a hacked router. Have you tried to reset it and see if it eliminates the issues you are having?

Edited by itman
Link to comment
Share on other sites

Hi ITMAN, thank you for your time. I did all the settings above but no use. If the Router has an issues then it affects other devices connected to the network right? but this problem is only with this computer. 

I have another Win 10 PC with Smart Security 9. That PC's ESS shows some blockage but never disconnect the internet. It's uses default settings with Home and Office Network with Automatic Firewall filtering mode. Also, it didn't use any of the above settings as you explained. No issues with this PC.

Is there any connection with Windows 10 pro and Windows 10 Home? For Windows 10 Pro computer works fine with ESS9. And the affected PC uses Windows 10 Home.

Link to comment
Share on other sites

6 hours ago, w3sumesh said:

I have another Win 10 PC with Smart Security 9. That PC's ESS shows some blockage but never disconnect the internet. It's uses default settings with Home and Office Network with Automatic Firewall filtering mode. Also, it didn't use any of the above settings as you explained. No issues with this PC.

The PC you're having issues with is using the Public profile per the previous screen shots you posted. Switch it to the Home and Office profile to see if that resolves your issues. Additionally with the profile set to Home and Office, you can run the new "Home Network Protection" troubleshooter in ver. 10 to determine if the network has any vulnerability issues. 

Link to comment
Share on other sites

1 hour ago, itman said:

The PC you're having issues with is using the Public profile per the previous screen shots you posted. Switch it to the Home and Office profile to see if that resolves your issues. Additionally with the profile set to Home and Office, you can run the new "Home Network Protection" troubleshooter in ver. 10 to determine if the network has any vulnerability issues. 

Thanks itman, I tried both network type. But same problem. 

Public and Home & Office. Public network is the system setting. And the Windows Network settings, the main connection type is Public. Please see two screenshots below.

One more thing, if I take my PC to Office or tither from mobile connection, there is no issues. Only within my home network is the issue, but NO other PC or devices in my Home network have the same issue My Laptop is brand new. I'm sure there is something to do with my Firewall settings.

I have provided the log but the Admins are not attending now.

home-public.thumb.JPG.83da2c49388ceef8a0e1d6a044510979.JPG

connection2.JPG.19a6dd291b2bf4384e298f0bd3ead9d2.JPG

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...