Jump to content

Archived

This topic is now archived and is closed to further replies.

SilentDave

No IMEI Required? Enrollment only on same LAN?

Recommended Posts

I'm confused about how to enroll new mobile devices.

Versions:

ESET Remote Administrator Agent    6.4.293.0
ESET Remote Administrator Mobile Device Connector    6.4.243.0
ESET Remote Administrator Server    6.4.304.0

 

Do you guys want to tell me that i need to connect my smartphone to the same network as server? why?

Is there a way to add devices the "old" way by IMEI

When i try to do it by enrollment link from email (external network) i get error message that shows device have no permission.

Share this post


Link to post
Share on other sites

Devices that i added earlier are comunicating ok with server till today. 

Problem is with new devices i cannot add any new device.

Share this post


Link to post
Share on other sites

In order to connect the mobile device to the mobile device connector, (MDC) mobile device needs to be able to connect to MDM Connector (MDC).

Have you performed an upgrade from the previous ERA / MDC version?

Enrollment works in the way, that ERA / MDC issues a one time enrollment token, which is individual per each mobile device. Therefore you do not have to white-list explicitly devices by IMEI, you can just send e-mails to the users, to click on the link.

Share this post


Link to post
Share on other sites

Yes i perfomed an upgrade.

I'm sending email and when i click on the link i got error device not authorized. 

 

Share this post


Link to post
Share on other sites

Hello,

just in case, are you using the latest Android app? When you try to enter the connection manually into the app, do you get one edit box for the entire enrollment URL, or two editboxes, for server name and port? (The app with one editbox is the newer version, needed for enrolling to 6.4 MDM)

Share this post


Link to post
Share on other sites

Ok i solved my problem.

I looked at ERA Server mysql database and found that IMEI's of the devices that i wanted to add was already there, but not visible in ERA Console.

The problem comes when something fails during device enrollment. I think IMEI is stored in the database no matter if enrollment is sucessfull or not.

If i removed those records and tried to enroll again it worked without problems.

That was in the trace.log when i wanted to enroll again after first unsuccessfull enrolment.

"[MySQL][ODBC 5.1 Driver][mysqld-5.5.53-0+deb8u1]Duplicate entry 'XX98720XX508556' for key 'PRIMARY'"

I rplaced some numbers with X.

Share this post


Link to post
Share on other sites

Thanks for the follow up and the solution.

It seems indeed possible to come into such a bad state, when a device is enrolled (from MDM's point of view) and the device itself is deenrolled (uninstall app (Android) / remove enrollment profile (iOS)) without being able to report that to MDM. Trying to re-enroll such a device will hit an error; however, MDM should report the old enrollment to ERA, so you should have seen a "ghost" device in the ERA webconsole; executing a "Stop managing" task for that device should fix things altogether - re-enrollment should start working again, because MDM would have deleted the device from its DB.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...