Jump to content

Firefox not working when Internet Protection is activated


Recommended Posts

Dear all,

I've recently acquired ESET Smart Security Premium and since I've activated it, I've been having problems with Firefox.

Basically, I cannot run Firefox unless I'm doing it so on Safe Mode. I'm currently using Vivaldi, Chrome and/or Edge and I'm not having any problems at all.

I've tried many things, but Firefox only works when I deactivate the internet protection options on my ESET. If I turn everything off, Firefox opens, no problem. If I reactivate the internet security options, Firefox does not loads (it opens and keeps giving me the "not responding" message).

Can you help me?

Thanks in advance!

 

Damián

Link to comment
Share on other sites

  • 1 month later...

I've just installed ESET Internet Security 10 and then installed Mozilla Firefox and Thunderbird, and had issues with internet pages and couldn't even install add-ons in Firefox, and email couldn't be sent/received.

I had Smart Security which had expired Nov 2016 so I remember I had the same problem a long time ago.

What solved it for me was I had to go into ESET 'Advanced Setup', then "WEB & EMAIL", then click on the + next to "SSL/TLS", then scroll down to "ROOT CERTIFICATE". Disable (move the tick to the right), then "OK". Now put the tick back to the left, then "OK". After this is done, reboot computer and see if it now works properly.

I had to do this to other user accounts also, and I think I had to temporarily change them from a standard account to administrator account until the changes/reboots were done.

Edited by chnmanz
added extra info.
Link to comment
Share on other sites

  • Administrators

We don't recommend disabling SSL filtering as it would disable HTTPS and POP3S/IMAPS filtering and scanning. It should be done only as a part of troubleshooting. However, when re-enabling SSL scanning, it's important that no browser and email client processes (Thunderbird, Windows Mail) be running.

If SSL filtering appears to be the culprit, try the following:
- Disable SSL filtering.
- Restart the computer.
- Without launching any browser or email client, re-enable SSL filtering (a new root certificate will be generated and imported do trusted root certification authority certificate stores).
- Try to reproduce the problem.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...