Jump to content

SessionNotValidException while authenticating in web console


PF4Public
 Share

Recommended Posts

Hello
I have installed ERA web console and it is operating normally on 8080 port. I can log in with Administrator account and so on (except license cannot be activated as per another topic).
I have tried to pass the traffic through nginx so as to use http2 and tls, but authentication fails with "//EX[0,1,["sk.eset.era.commons.common.model.exceptions.SessionNotValidException/****"],0,7]" reply immediately after "//OK[1,["****\x3D\x3D"],0,7]".

Nginx config is as follows:



server {
listen 80;
server_name era.****;
access_log /var/log/nginx/era.insecure.access.log;
return 301 https://era.****$request_uri;
}

server {
listen 443 ssl http2;
server_name era.****;
access_log /var/log/nginx/era.access.log;
add_header Strict-Transport-Security "max-age=31536000; includeSubdomains;";
ssl_certificate ssl/era-chained.crt;
ssl_certificate_key ssl/era.key;
location / {
proxy_pass hxxp://localhost:8080/;
}}

I have tried following settings:



proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;

But this didn't help.

Please advice on how to resolve this issue.

Thanks.

Link to comment
Share on other sites

  • 2 months later...

Their support was kind enough to help identify the cause of this issue. It turned out that nginx resolved "localhost" as both ipv4 and ipv6, thus was sending requests using both of these IPs, which was blocked by ERA. Solution is to use "127.0.0.1" instead.

Posting just in case anyone has the same issue.

 

Edited by PF4Public
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...