Jump to content

Virgo Pärna

Members
  • Content Count

    9
  • Joined

  • Last visited

Profile Information

  • Location
    Estonia
  1. libssl1.0.0 package from jessie is actually version 1.0.1t. And when I tried now again, it worked. And from checking the bash history it appears that previously I made an error linking libcrypto.so.1.0.0 Sot that it works now and is updated as long as Jessie is updated. Thanks for help.
  2. Ok, I can try Wireshark at Monday. But that is probably the reason. 3DES is disabled at stretch version of openssl. And while jessie version of libssl1.0.0 is still installed the eraserver would not work with it (with libssl and libcrypto linked to 1.0.0 version). I guess that monitoring would not work with that computer anymore. Since it is not actively used, it really is not much of a issue. At least it is good to know the reason.
  3. An on the server side the errors are: Error: NetworkModule [Thread aa6f6b40]: Receive: NodSslWriteEncryptedData: Internal error in the underlying implementations., ResolvedIpAddress:10.10.10.36, ResolvedHostname:clientname, ResolvedPort:1758 Error: NetworkModule [Thread aa6f6b40]: Protocol failure for session id 1557, error:Receive: NodSslWriteEncryptedData: Internal error in the underlying implementations.
  4. Interestingly one XP computer, that we still have around fails handshake when connecting to server: Error: CReplicationModule [Thread e94]: CReplicationManager: Replication (network) connection to 'host: "servername" port: 2222' failed with: Receive: NodSslWriteEncryptedData: Handshake failed to complete. TLS 1.0 is still supported, so that should not be an issue.
  5. Thanks. Creating links in /opt/eset/RemoteAdministrator/Server for libcrypto.so -> /usr/lib/i386-linux-gnu/libcrypto.so.1.0.2 libssl.so -> /usr/lib/i386-linux-gnu/libssl.so.1.0.2 seems to have fixed the issue for now.
  6. And since I forgot to mention server version: ProductVersion: 6.5.417.0 in the same log file.
  7. After upgrading server operating system to Debian Stretch (was Jessie) eraserver fails to start up with "SSL initialization failed". (in trace.log). 2017-11-24 12:54:59 Information: Kernel [Thread b7507980]: Loading module library Network 2017-11-24 12:55:00 Error: Service [Thread b7507980]: SSL initialization failed I have following ssl libraris installed: libssl1.0.0 libssl1.0.2 libssl1.1
  8. Restoring database and reinstalling upgrade worked (if I did not touch the server after reinstall). Part of the problem is, that during installation it mentions upgrading database and the reports, that it is done. And then it does not mention, that it restarted the daemon. So my natural process was to install the upgrade and then restart the daemon (to start new version).
  9. There appears to be some kind of problem with database structure with Remote Administration server 6.5.417.0 for Linux (at least using MySQL database). Server fails to start up with "Table 'era_db.tbl_log_apps_installed_status' doesn't exist" message in lasterror.html file. This table and many others existed in version 6.4, but they are not anymore in database creation scripts in newest version. And according to tbl_database_version the database version should be 6517.
×
×
  • Create New...